Installing Logstash on older versions of RedHat can be a real pain. If you are struck with the familiar LoadError: Could not load FFI Provider: (NotImplementedError) FFI not available: null then follow on! First things first how to install Logstash on RedHat 5.4: sudo rpm -Uvh http://download.elasticsearch.…